Odoo8 – Erreur « new encoding (UTF8) is incompatible with … (SQL_ASCII) »

Ayant installé chez un nouvel hébergeur, Odoo 8 sur Debian 7.8, j'ai rencontré l'erreur suivante lors de la création de la base de données :
DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
HINT:  Use the same encoding as in the template database, or use template0 as template.

Pour résoudre cette erreur, j'ai choisi la solution suivante :
dpkg-reconfigure locales
   > choisir fr_FR.UTF-8

- profitons en aussi pour configurer le bon fuseau horaire (Europe/Paris)
dpkg-reconfigure tzdata

- se reconnecter pour prendre en compte la modification
- ré-installer la BD postgresql et recréer l'utilisateur "odoo"
- relancer Odoo

Une autre solution existe (si besoin, remplacer 9.1 par votre version postgresql) :
pg_dropcluster --stop 9.1 main
pg_createcluster --start -e UTF-8 9.1 main

3 réflexions au sujet de « Odoo8 – Erreur « new encoding (UTF8) is incompatible with … (SQL_ASCII) » »

  1. Bonjour,

    par :
    – se reconnecter pour prendre en compte la modification
    – ré-installer la BD postgresql et recréer l'utilisateur "odoo"
    – relancer Odoo

    ie
    1/ se deconnecter et se reconnecter en root ?
    2/ réinstaller postgresql "apt-get install postgresql " et ensuite :
    su – postgres
    psql
    password postgres
    password odoo
    q
    c'est ça ?
    3/ relancer odoo

    Excuse moi, je suis assez nouveau en linux.

    Merci

    1. Après avoir subi à nouveau la même erreur, voici ce que j'ai fait :

      >Pour réinstaller PostgreSQL :
      apt-get –purge remove postgresql*
      apt-get install postgresql

      >Pour recréer le user "odoo" :
      ./odoo/odoo.py setup_pg

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *